php-proxy vulnerabilities and exploits