cve-2014-3979 vulnerabilities and exploits