arbitrary code vulnerabilities and exploits