hisuite vulnerabilities and exploits

7.2
CVSSv2
CVE-2016-5821

Huawei HiSuite before 4.0.4.204_ove (Out of China) and before 4.0.4.301 (China) use a weak ACL (FILE_WRITE_DATA for BUILTIN\Users) for the HiSuite service directory, which allows local users to gain SYSTEM privileges via a Trojan horse (1) SspiCli.dll or (2) USERENV.dll file or...

6.9
CVSSv2
CVE-2016-8273

Huawei PC client software HiSuite 4.0.5.300_OVE uses insecure HTTP for upgrade software package download and does not check the integrity of the software package before installing; an attacker can launch an MITM attack to interrupt or replace the downloaded software package and...

2.9
CVSSv2
CVE-2016-4086

Huawei HiSuite (In China) before 4.0.4.301 and (Out of China) before 4.0.4.204_ove allows remote attackers to install arbitrary apps on a connected phone via unspecified vectors....

2.1
CVSSv2
CVE-2016-8272

Huawei PC client software HiSuite 4.0.5.300_OVE has an information leak vulnerability; an attacker who can log in to the system can copy out the user's proxy password, causing information leaks....

7.2
CVSSv2
CVE-2016-8274

Huawei PC client software HiSuite 4.0.5.300_OVE has a dynamic link library (DLL) hijack vulnerability; an attacker can make the system load malicious DLL files to execute arbitrary code....

4.6
CVSSv2
CVE-2019-5245

HiSuite 9.1.0.300 versions and earlier contains a DLL hijacking vulnerability. This vulnerability exists due to some DLL file is loaded by HiSuite improperly. And it allows an attacker to load this DLL file of the attacker's choosing that could execute arbitrary code....

NA
CVE-2017-5245

** REJECT ** DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: none. Reason: This candidate was withdrawn by its CNA. Further investigation showed that it was not a security issue. Notes: none....

NA
CVE-2019-5226

Huawei smartphones could provide weaker than expected security, caused by improper validation of upgrade package. A local attacker could exploit this vulnerability to perform a version downgrade attack....

NA
CVE-2019-5227

Huawei smartphones could provide weaker than expected security, caused by improper validation of upgrade package. A local attacker could exploit this vulnerability to perform a version downgrade attack....