BSA-2017-429

Related Vulnerabilities: CVE-2017-9793  

Summary

A flaw was found in the Struts REST plugin when using an outdated XStream library. An attacker could perform a denial of service attack using a malicious request with specially crafted XML payload.

Affected Products

Brocade is investigating its product lines to determine which products may be affected by this vulnerability and the impact on each affected product.

Products Confirmed Not Vulnerable

Brocade Fabric OS, Brocade NetIron OS, Brocade Network OS, Brocade ServerIron ADX, Brocade SLX-OS, Brocade Virtual ADX, and Brocade Workflow Composer are confirmed not affected by this vulnerability.

Workaround

There are no workarounds that address this vulnerability.

Revision History

Version Change Date
1.0 Initial Publication September 8, 2017
2.0 Updated to address ADX, vADX, & WC October 13, 2017