7.5
CVSSv2

CVE-2008-4059

Published: 24/09/2008 Updated: 29/09/2017
CVSS v2 Base Score: 7.5 | Impact Score: 6.4 | Exploitability Score: 10
VMScore: 668
Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Summary

The XPConnect component in Mozilla Firefox prior to 2.0.0.17 allows remote malicious users to "pollute XPCNativeWrappers" and execute arbitrary code with chrome privileges via vectors related to a SCRIPT element.

Affected Products

Vendor Product Versions
MozillaFirefox*, 0.8, 0.9, 0.9.1, 0.9.2, 0.9.3, 0.9 Rc, 0.10, 0.10.1, 1.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8, 1.5, 1.5.0.1, 1.5.0.2, 1.5.0.3, 1.5.0.4, 1.5.0.5, 1.5.0.6, 1.5.0.7, 1.5.0.8, 1.5.0.9, 1.5.0.10, 1.5.0.11, 1.5.0.12, 1.5.1, 1.5.2, 1.5.3, 1.5.4, 1.5.5, 1.5.6, 1.5.7, 1.5.8, 1.8, 2.0, 2.0.0.1, 2.0.0.2, 2.0.0.3, 2.0.0.4, 2.0.0.5, 2.0.0.6, 2.0.0.7, 2.0.0.8, 2.0.0.9, 2.0.0.10, 2.0.0.11, 2.0.0.12, 2.0.0.13, 2.0.0.14, 2.0.0.15, 2.0.0.16, 2.0.0.17

Vendor Advisories

Synopsis Moderate: thunderbird security update Type/Severity Security Advisory: Moderate Topic Updated thunderbird packages that fix several security issues are nowavailable for Red Hat Enterprise Linux 4 and 5This update has been rated as having moderate security impact by the RedHat Security Response Tea ...
Synopsis Critical: seamonkey security update Type/Severity Security Advisory: Critical Topic Updated seamonkey packages that fix a security issues are now available forRed Hat Enterprise Linux 21, Red Hat Enterprise Linux 3 and Red HatEnterprise Linux 4This update has been rated as having critical securit ...
Privilege escalation via XPCnativeWrapper pollution Announced September 23, 2008 Reporter moz_bug_r_a4, Olli Pettay Impact Critical Products Firefox, SeaMonkey, Thunderbird Fixed in ...
It was discovered that the same-origin check in Thunderbird could be bypassed If a user had JavaScript enabled and were tricked into opening a malicious website, an attacker may be able to execute JavaScript in the context of a different website (CVE-2008-3835) ...
Justin Schuh, Tom Cross and Peter Williams discovered errors in the Firefox URL parsing routines If a user were tricked into opening a crafted hyperlink, an attacker could overflow a stack buffer and execute arbitrary code (CVE-2008-0016) ...

References

CWE-264http://download.novell.com/Download?buildid=WZXONb-tqBw~http://lists.opensuse.org/opensuse-security-announce/2008-10/msg00005.htmlhttp://secunia.com/advisories/31984http://secunia.com/advisories/31985http://secunia.com/advisories/32007http://secunia.com/advisories/32010http://secunia.com/advisories/32012http://secunia.com/advisories/32025http://secunia.com/advisories/32042http://secunia.com/advisories/32044http://secunia.com/advisories/32082http://secunia.com/advisories/32092http://secunia.com/advisories/32144http://secunia.com/advisories/32185http://secunia.com/advisories/32196http://secunia.com/advisories/32845http://secunia.com/advisories/33433http://secunia.com/advisories/33434http://secunia.com/advisories/34501http://slackware.com/security/viewer.php?l=slackware-security&y=2008&m=slackware-security.379422http://slackware.com/security/viewer.php?l=slackware-security&y=2008&m=slackware-security.405232http://slackware.com/security/viewer.php?l=slackware-security&y=2008&m=slackware-security.412123http://sunsolve.sun.com/search/document.do?assetkey=1-26-256408-1http://www.debian.org/security/2008/dsa-1649http://www.debian.org/security/2008/dsa-1669http://www.debian.org/security/2009/dsa-1696http://www.debian.org/security/2009/dsa-1697http://www.mandriva.com/security/advisories?name=MDVSA-2008:205http://www.mandriva.com/security/advisories?name=MDVSA-2008:206http://www.mozilla.org/security/announce/2008/mfsa2008-41.htmlhttp://www.redhat.com/support/errata/RHSA-2008-0882.htmlhttp://www.redhat.com/support/errata/RHSA-2008-0908.htmlhttp://www.securityfocus.com/bid/31346http://www.securitytracker.com/id?1020915http://www.ubuntu.com/usn/usn-645-1http://www.ubuntu.com/usn/usn-645-2http://www.ubuntu.com/usn/usn-647-1http://www.vupen.com/english/advisories/2008/2661http://www.vupen.com/english/advisories/2009/0977https://bugzilla.mozilla.org/show_bug.cgi?id=419848https://exchange.xforce.ibmcloud.com/vulnerabilities/45352https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9529https://www.redhat.com/archives/fedora-package-announce/2008-September/msg01384.htmlhttps://www.redhat.com/archives/fedora-package-announce/2008-September/msg01403.htmlhttp://tools.cisco.com/security/center/viewAlert.x?alertId=16734https://nvd.nist.govhttps://www.rapid7.com/db/vulnerabilities/gentoo-linux-cve-2008-4062https://usn.ubuntu.com/647-1/