9.3
CVSSv2

CVE-2010-2171

Published: 15/06/2010 Updated: 30/10/2018
CVSS v2 Base Score: 9.3 | Impact Score: 10 | Exploitability Score: 8.6
VMScore: 828
Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Summary

Adobe Flash Player prior to 9.0.277.0 and 10.x prior to 10.1.53.64, and Adobe AIR prior to 2.0.2.12610, allows malicious users to cause a denial of service (memory corruption) or possibly execute arbitrary code via vectors related to SWF files, decompression of embedded JPEG image data, and the DefineBits and other unspecified tags, a different vulnerability than CVE-2010-2160, CVE-2010-2165, CVE-2010-2166, CVE-2010-2175, CVE-2010-2176, CVE-2010-2177, CVE-2010-2178, CVE-2010-2180, CVE-2010-2182, CVE-2010-2184, CVE-2010-2187, and CVE-2010-2188.

Most Upvoted Vulmon Research Post

There is no Researcher post for this vulnerability
Would you like to share something about it? Sign up now to share your knowledge with the community.
Vulnerable Product Search on Vulmon Subscribe to Product

adobe flash player 9.0.124.0

adobe flash player 9.0.115.0

adobe flash player 9.0.20.0

adobe flash player 9.0.20

adobe flash player 9.0.159.0

adobe flash player 9.0.152.0

adobe flash player 9.0.45.0

adobe flash player 9.0.31.0

adobe flash player 9.0.28

adobe flash player 9.0.260.0

adobe flash player 9.0.246.0

adobe flash player 9.0.125.0

adobe flash player 9.0.48.0

adobe flash player 9.0.262.0

adobe flash player 9.0.47.0

adobe flash player 9.0.16

adobe flash player 9.0.28.0

adobe flash player 9.0.31

adobe flash player 9.0.151.0

adobe flash player 10.0.15.3

adobe flash player

adobe flash player 10.0.32.18

adobe flash player 10.0.42.34

adobe flash player 10.0.22.87

adobe flash player 10.0.0.584

adobe flash player 10.0.12.10

adobe flash player 10.0.12.36

adobe flash player 7.0.70.0

adobe flash player 7.0.63

adobe flash player 7.0.69.0

adobe flash player 7.0.24.0

adobe flash player 7.0.53.0

macromedia flash player 5.0.30.0

macromedia flash player 5.0.58.0

adobe flash player 8.0.24.0

adobe flash player 8.0.33.0

adobe flash player 7.1

adobe flash player 7.0.60.0

macromedia flash player 5.0

adobe flash player 7.0.14.0

adobe flash player 6.0.79

adobe flash player 7.0.66.0

adobe flash player 7.1.1

adobe flash player 7.0.19.0

adobe flash player 8.0.35.0

adobe flash player 7.0.67.0

adobe flash player 8.0.22.0

macromedia flash player 5.0.42.0

adobe flash player 8.0.42.0

adobe flash player 7.0

adobe flash player 7.2

adobe flash player 7.0.68.0

macromedia flash player 5.0.41.0

adobe flash player 7.0.25

adobe flash player 8.0

adobe flash player 8.0.39.0

adobe flash player 7.0.73.0

adobe flash player 8.0.34.0

adobe flash player 7.0.61.0

adobe flash player 7.0.1

adobe air 1.1

adobe air 1.5

adobe air 1.5.1

adobe air 1.5.2

adobe air 1.5.3

adobe air 1.0

adobe air

References

CWE-119http://securitytracker.com/id?1024085http://www.securityfocus.com/bid/40759http://www.adobe.com/support/security/bulletins/apsb10-14.htmlhttp://securitytracker.com/id?1024086http://www.redhat.com/support/errata/RHSA-2010-0470.htmlhttp://www.us-cert.gov/cas/techalerts/TA10-162A.htmlhttp://www.vupen.com/english/advisories/2010/1453http://www.redhat.com/support/errata/RHSA-2010-0464.htmlhttp://www.securityfocus.com/bid/40784http://www.vupen.com/english/advisories/2010/1421http://www.vupen.com/english/advisories/2010/1434http://secunia.com/advisories/40144http://www.vupen.com/english/advisories/2010/1482http://lists.opensuse.org/opensuse-security-announce/2010-06/msg00001.htmlhttp://lists.opensuse.org/opensuse-security-announce/2010-06/msg00000.htmlhttp://www.vupen.com/english/advisories/2010/1432http://www.vupen.com/english/advisories/2010/1522http://www.turbolinux.co.jp/security/2010/TLSA-2010-19j.txthttp://www.zerodayinitiative.com/advisories/ZDI-10-110http://secunia.com/advisories/40545http://itrc.hp.com/service/cki/docDisplay.do?docId=emr_na-c02273751http://www.vupen.com/english/advisories/2010/1793http://lists.apple.com/archives/security-announce/2010//Nov/msg00000.htmlhttp://support.apple.com/kb/HT4435http://security.gentoo.org/glsa/glsa-201101-09.xmlhttp://www.vupen.com/english/advisories/2011/0192http://secunia.com/advisories/43026https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A6999https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A16341http://www.securityfocus.com/archive/1/511860/100/0/threadedhttps://nvd.nist.govhttps://www.securityfocus.com/bid/40784