4.3
CVSSv2

CVE-2012-4000

Published: 12/07/2012 Updated: 29/08/2017
CVSS v2 Base Score: 4.3 | Impact Score: 2.9 | Exploitability Score: 8.6
VMScore: 435
Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Summary

Cross-site scripting (XSS) vulnerability in the print_textinputs_var function in editor/dialog/fck_spellerpages/spellerpages/server-scripts/spellchecker.php in FCKeditor 2.6.7 and previous versions allows remote malicious users to inject arbitrary web script or HTML via textinputs array parameters.

Most Upvoted Vulmon Research Post

There is no Researcher post for this vulnerability
Would you like to share something about it? Sign up now to share your knowledge with the community.
Vulnerable Product Search on Vulmon Subscribe to Product

ckeditor fckeditor 2.6.3

ckeditor fckeditor 2.5

ckeditor fckeditor 2.4.3

ckeditor fckeditor 2.3

ckeditor fckeditor 2.0

ckeditor fckeditor 1.2.2

ckeditor fckeditor 1.2

ckeditor fckeditor 0.9.4

ckeditor fckeditor 0.9.3

ckeditor fckeditor

ckeditor fckeditor 2.6.5

ckeditor fckeditor 2.6

ckeditor fckeditor 2.4

ckeditor fckeditor 2.3.3

ckeditor fckeditor 2.1

ckeditor fckeditor 1.4

ckeditor fckeditor 1.3.1

ckeditor fckeditor 1.0

ckeditor fckeditor 0.8.5

ckeditor fckeditor 0.8

ckeditor fckeditor 2.6.4

ckeditor fckeditor 2.6.4.1

ckeditor fckeditor 2.5.1

ckeditor fckeditor 2.3.2

ckeditor fckeditor 2.3.1

ckeditor fckeditor 1.3

ckeditor fckeditor 1.2.4

ckeditor fckeditor 0.9.5

ckeditor fckeditor 2.6.2

ckeditor fckeditor 2.6.1

ckeditor fckeditor 2.4.2

ckeditor fckeditor 2.4.1

ckeditor fckeditor 2.2

ckeditor fckeditor 2.1.1

ckeditor fckeditor 1.6

ckeditor fckeditor 1.5

ckeditor fckeditor 1.1

ckeditor fckeditor 0.9.2

ckeditor fckeditor 0.9.1

ckeditor fckeditor 0.9.0

Vendor Advisories

Emilio Pinna discovered a cross site scripting vulnerability in the spellcheckerphp page of FCKeditor, a popular HTML/DHTML editor for the web For the stable distribution (squeeze), this problem has been fixed in version 1:266-1squeeze1 For the testing distribution (wheezy), this problem has been fixed in version 1:266-3 For the unstable di ...

Exploits

source: wwwsecurityfocuscom/bid/54188/info FCKEditor is prone to a cross-site scripting vulnerability because it fails to sanitize user-supplied input An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site This may allow the attacker to steal cooki ...

Mailing Lists

FCKeditor versions 2610 and below suffer from a cross site scripting vulnerability ...