7.5
CVSSv2

CVE-2014-1691

Published: 01/04/2014 Updated: 02/04/2014
CVSS v2 Base Score: 7.5 | Impact Score: 6.4 | Exploitability Score: 10
VMScore: 795
Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Summary

The framework/Util/lib/Horde/Variables.php script in the Util library in Horde prior to 5.1.1 allows remote malicious users to conduct object injection attacks and execute arbitrary PHP code via a crafted serialized object in the _formvars form.

Vulnerable Product Search on Vulmon Subscribe to Product

horde horde application framework 5.0.0

horde horde application framework 5.0.1

horde horde application framework 5.0.2

horde horde application framework 5.0.3

horde horde application framework 5.0.4

horde horde application framework

Vendor Advisories

Debian Bug report logs - #737149 CVE-2014-1691: Remote code execution in horde < 511 Package: horde3; Maintainer for horde3 is (unknown); Reported by: Micah Anderson <micah@debianorg> Date: Thu, 30 Jan 2014 17:03:02 UTC Severity: serious Tags: security Found in version horde3/338+debian0-2 Fixed in version horde3 ...
Pedro Ribeiro from Agile Information Security found a possible remote code execution on Horde3, a web application framework Unsanitized variables are passed to the unserialize() PHP function A remote attacker could specially-craft one of those variables allowing her to load and execute code For the oldstable distribution (squeeze), this problem ...

Exploits

## # This module requires Metasploit: http//metasploitcom/download # Current source: githubcom/rapid7/metasploit-framework ## require 'msf/core' class Metasploit3 < Msf::Exploit::Remote Rank = ExcellentRanking include Msf::Exploit::Remote::HttpClient def initialize(info = {}) super(update_info(info, 'Name' ...

Mailing Lists

This Metasploit module exploits a php unserialize() vulnerability in Horde versions 511 and below which could be abused to allow unauthenticated users to execute arbitrary code with the permissions of the web server The dangerous unserialize() exists in the 'lib/Horde/Variablesphp' file The exploit abuses the __destruct() method from the Horde ...

Metasploit Modules

Horde Framework Unserialize PHP Code Execution

This module exploits a php unserialize() vulnerability in Horde <= 5.1.1 which could be abused to allow unauthenticated users to execute arbitrary code with the permissions of the web server. The dangerous unserialize() exists in the 'lib/Horde/Variables.php' file. The exploit abuses the __destruct() method from the Horde_Kolab_Server_Decorator_Clean class to reach a dangerous call_user_func() call in the Horde_Prefs class.

msf > use exploit/unix/webapp/horde_unserialize_exec
      msf exploit(horde_unserialize_exec) > show targets
            ...targets...
      msf exploit(horde_unserialize_exec) > set TARGET <target-id>
      msf exploit(horde_unserialize_exec) > show options
            ...show and set options...
      msf exploit(horde_unserialize_exec) > exploit