NA

CVE-2014-2314

Published: 09/03/2014 Updated: 29/07/2015
CVSS v2 Base Score: 4.3 | Impact Score: 2.9 | Exploitability Score: 8.6
VMScore: 475
Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Summary

Directory traversal vulnerability in the Issue Collector plugin in Atlassian JIRA prior to 6.0.4 allows remote malicious users to create arbitrary files via unspecified vectors.

Vulnerable Product Search on Vulmon Subscribe to Product

atlassian jira 6.0

atlassian jira 6.0.1

atlassian jira 6.0.2

atlassian jira

Exploits

## # This module requires Metasploit: http//metasploitcom/download # Current source: githubcom/rapid7/metasploit-framework ## require 'msf/core' class Metasploit3 < Msf::Exploit::Remote Rank = NormalRanking include Msf::Exploit::Remote::HttpClient include Msf::Exploit::EXE include Msf::Exploit::FileDropper def initialize( ...

Metasploit Modules

JIRA Issues Collector Directory Traversal

This module exploits a directory traversal flaw in JIRA 6.0.3. The vulnerability exists in the issues collector code, while handling attachments provided by the user. It can be exploited in Windows environments to get remote code execution. This module has been tested successfully on JIRA 6.0.3 with Windows 2003 SP2 Server.

msf > use exploit/windows/http/jira_collector_traversal
      msf exploit(jira_collector_traversal) > show targets
            ...targets...
      msf exploit(jira_collector_traversal) > set TARGET <target-id>
      msf exploit(jira_collector_traversal) > show options
            ...show and set options...
      msf exploit(jira_collector_traversal) > exploit