4.3
CVSSv2

CVE-2017-9936

Published: 26/06/2017 Updated: 03/10/2019
CVSS v2 Base Score: 4.3 | Impact Score: 2.9 | Exploitability Score: 8.6
CVSS v3 Base Score: 6.5 | Impact Score: 3.6 | Exploitability Score: 2.8
VMScore: 435
Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Vulnerability Summary

In LibTIFF 4.0.8, there is a memory leak in tif_jbig.c. A crafted TIFF document can lead to a memory leak resulting in a remote denial of service attack.

Affected Products

Vendor Product Versions
LibtiffLibtiff4.0.8
CanonicalUbuntu Linux14.04, 16.04
DebianDebian Linux8.0, 9.0, 10.0

Vendor Advisories

In LibTIFF 408, there is a memory leak in tif_jbigc A crafted TIFF document can lead to a memory leak resulting in a remote denial of service attack ...
Debian Bug report logs - #866611 tiff: CVE-2017-10688 Package: src:tiff; Maintainer for src:tiff is Laszlo Boszormenyi (GCS) <gcs@debianorg>; Reported by: Salvatore Bonaccorso <carnil@debianorg> Date: Fri, 30 Jun 2017 13:57:01 UTC Severity: important Tags: security, upstream Found in version tiff/408-2 Fixed in ...
Multiple vulnerabilities have been discovered in the libtiff library and the included tools, which may result in denial of service or the execution of arbitrary code For the oldstable distribution (jessie), these problems have been fixed in version 403-123+deb8u4 For the stable distribution (stretch), these problems have been fixed in version ...
Debian Bug report logs - #866113 tiff: CVE-2017-9936: Memory leak in tif_jbigc can lead to DoS Package: src:tiff; Maintainer for src:tiff is Laszlo Boszormenyi (GCS) <gcs@debianorg>; Reported by: Salvatore Bonaccorso <carnil@debianorg> Date: Tue, 27 Jun 2017 12:42:02 UTC Severity: important Tags: fixed-upstream, p ...
LibTIFF could be made to crash or run programs as your login if it opened a specially crafted file ...

Exploits

Source: bugzillamaptoolsorg/show_bugcgi?id=2706 Triggered by “/tiff2ps $POC” or “/tiff2pdf $POC” Triggered by “/tiff2ps $POC” or “/tiff2pdf $POC” The asan debug information is below: $/tiff2ps $POC ================================================================= ==26627==ERROR: LeakSanitizer: detected memory ...