7.5
CVSSv2

CVE-2019-10769

Published: 06/12/2019 Updated: 17/12/2019
CVSS v2 Base Score: 7.5 | Impact Score: 6.4 | Exploitability Score: 10
CVSS v3 Base Score: 9.8 | Impact Score: 5.9 | Exploitability Score: 3.9
Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Summary

Node.js safer-eval module could allow a remote authenticated malicious user to execute arbitrary code on the system, caused by a sandbox escape in the eval function. By sending specially-crafted request to generate a RangeError, an attacker could exploit this vulnerability to execute arbitrary code on the system.

Vulnerability Trend