6.8
CVSSv2

CVE-2019-12083

Published: 13/05/2019 Updated: 14/05/2019
CVSS v2 Base Score: 6.8 | Impact Score: 6.4 | Exploitability Score: 8.6
CVSS v3 Base Score: 8.1 | Impact Score: 5.9 | Exploitability Score: 2.2
Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Summary

The Rust Programming Language Standard Library 1.34.x prior to 1.34.2 contains a stabilized method which, if overridden, can violate Rust's safety guarantees and cause memory unsafety. If the `Error::type_id` method is overridden then any type can be safely cast to any other type, causing memory safety vulnerabilities in safe code (e.g., out-of-bounds write or read). Code that does not manually implement Error::type_id is unaffected.

Vulnerability Trend

Affected Products

Vendor Product Versions
Rust-langRust1.34.0, 1.34.1