5
MEDIUM

CVE-2019-1681

Published: 21/02/2019 Updated: 22/02/2019
CVSS v2 Base Score: 5 | Impact Score: 2.9 | Exploitability Score: 10
CVSS v3 Base Score: 7.5 | Impact Score: 3.6 | Exploitability Score: 3.9

Vulnerability Summary

A vulnerability in the TFTP service of Cisco Network Convergence System 1000 Series software could allow an unauthenticated, remote malicious user to retrieve arbitrary files from the targeted device, possibly resulting in information disclosure. The vulnerability is due to improper validation of user-supplied input within TFTP requests processed by the affected software. An attacker could exploit this vulnerability by using directory traversal techniques in malicious requests sent to the TFTP service on a targeted device. An exploit could allow the malicious user to retrieve arbitrary files from the targeted device, resulting in the disclosure of sensitive information. This vulnerability affects Cisco IOS XR Software releases prior to Release 6.5.2 for Cisco Network Convergence System 1000 Series devices when the TFTP service is enabled.

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Complexity: LOW
Authentication: NONE
Access Vector: NETWORK
Confidentiality Impact: PARTIAL
Integrity Impact: NONE
Availability Impact: NONE

Vulnerability Trend

Affected Products

Vendor Product Versions
CiscoIos Xr-, 2.0, 2.0(.0), 2.0.0, 3.0, 3.0(.0), 3.0(.1), 3.0.0, 3.0.1, 3.1, 3.1.0, 3.2, 3.2(.0), 3.2(.1), 3.2(.2), 3.2(.3), 3.2(.4), 3.2(.6), 3.2(.50), 3.2.0, 3.2.1, 3.2.2, 3.2.3, 3.2.4, 3.2.6, 3.2.50, 3.3, 3.3(.0), 3.3(.1), 3.3(.2), 3.3(.3), 3.3(.4), 3.3.0, 3.3.1, 3.3.2, 3.3.3, 3.3.4, 3.3.5, 3.4, 3.4(.0), 3.4(.1), 3.4(.2), 3.4(.3), 3.4.0, 3.4.1, 3.4.2, 3.4.3, 3.5, 3.5(.0), 3.5(.1), 3.5(.2), 3.5(.3), 3.5(.4), 3.5.0, 3.5.1, 3.5.2, 3.5.3, 3.5.4, 3.6, 3.6(.1), 3.6(.2), 3.6(.3), 3.6.0, 3.6.1, 3.6.2, 3.6.3, 3.6 Base, 3.7, 3.7(.1), 3.7(.2), 3.7(.3), 3.7.0, 3.7.1, 3.7.2, 3.7.3, 3.7 Base, 3.8(.0), 3.8(.1), 3.8(.2), 3.8(.3), 3.8(.4), 3.8.0, 3.8.1, 3.8.2, 3.8.3, 3.8.4, 3.9(.0), 3.9(.1), 3.9(.2), 3.9.0, 3.9.1, 3.9.2, 3.9.3, 4.0(.0), 4.0(.1), 4.0(.2), 4.0(.3), 4.0(.4), 4.0(.11), 4.0.0, 4.0.1, 4.0.2, 4.0.3, 4.0.4, 4.0.11, 4.0 Base, 4.1, 4.1(.0), 4.1(.1), 4.1(.2), 4.1.0, 4.1.1, 4.1.2, 4.1 Base, 4.2(.0), 4.2(.1), 4.2(.2), 4.2(.3), 4.2(.4), 4.2.0, 4.2.1, 4.2.2, 4.2.3, 4.2.4, 4.3(.0), 4.3.0, 4.3.1, 4.3.2, 4.3.3, 4.3.4, 5.0.0, 5.0.1, 5.0 Base, 5.1.0, 5.1.1, 5.1.1.k9sec, 5.1.2, 5.1.3, 5.2.0, 5.2.1, 5.2.2, 5.2.4, 5.3.0, 5.3.0 Base, 5.3.2, 6.0.0, 6.0.1, 6.0.2, 6.0.2.01, 6.0 Base, 6.1.0, 6.1.1, 6.2.1, 6.4.1 Base

Vendor Advisories

A vulnerability in the TFTP service of Cisco Network Convergence System 1000 Series software could allow an unauthenticated, remote attacker to retrieve arbitrary files from the targeted device, possibly resulting in information disclosure The vulnerability is due to improper validation of user-supplied input within TFTP requests processed by the ...

References