NA

CVE-2020-28975

Published: 21/11/2020 Updated: 30/11/2020

Vulnerability Summary

** DISPUTED ** svm_predict_values in svm.cpp in Libsvm v324, as used in scikit-learn 0.23.2 and other products, allows malicious users to cause a denial of service (segmentation fault) via a crafted model SVM (introduced via pickle, json, or any other model permanence standard) with a large value in the _n_support array. NOTE: the scikit-learn vendor's position is that the behavior can only occur if the library's API is violated by an application that changes a private attribute.

Vulnerability Trend

Mailing Lists

[Description] svm_predict_values in svmcpp in Libsvm v324, as used in scikit-learn 0232 and other products, allows attackers to cause a denial of service (segmentation fault) via a crafted model SVM (introduced via pickle, json, or any other model permanence technique) with a large value in the _n_support array [CVE ID] CVE-2020-28975 ...