2.1
CVSSv2

CVE-2004-1270

Published: 10/01/2005 Updated: 03/10/2018
CVSS v2 Base Score: 2.1 | Impact Score: 2.9 | Exploitability Score: 3.9
VMScore: 187
Vector: AV:L/AC:L/Au:N/C:N/I:P/A:N

Vulnerability Summary

lppasswd in CUPS 1.1.22, when run in environments that do not ensure that file descriptors 0, 1, and 2 are open when lppasswd is called, does not verify that the passwd.new file is different from STDERR, which allows local users to control output to passwd.new via certain user input that triggers an error message.

Affected Products

Vendor Product Versions
Easy Software ProductsCups1.0.4, 1.0.4 8, 1.1.1, 1.1.4, 1.1.4 2, 1.1.4 3, 1.1.4 5, 1.1.6, 1.1.7, 1.1.10, 1.1.12, 1.1.13, 1.1.14, 1.1.15, 1.1.16, 1.1.17, 1.1.18, 1.1.19, 1.1.19 Rc5, 1.1.20, 1.1.21, 1.1.22 Rc1
RedhatFedora CoreCore 2.0, Core 3.0

Vendor Advisories

Synopsis cups security update Type/Severity Security Advisory: Important Topic Updated CUPS packages that fix several security issues are now available Description The Common UNIX Printing System provides a portable printing layer forUNIX(R) operating systemsA buffer overflow was found in ...
Synopsis CUPS security update Type/Severity Security Advisory: Important Topic Updated CUPS packages that fix several security issues are now availableThis update has been rated as having important security impact by the Red HatSecurity Response Team Description The Common UNIX Printing S ...