445
VMScore

CVE-2011-1184

Published: 14/01/2012 Updated: 25/03/2019
CVSS v2 Base Score: 5 | Impact Score: 2.9 | Exploitability Score: 10
VMScore: 445
Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Vulnerability Summary

The HTTP Digest Access Authentication implementation in Apache Tomcat 5.5.x prior to 5.5.34, 6.x prior to 6.0.33, and 7.x prior to 7.0.12 does not have the expected countermeasures against replay attacks, which makes it easier for remote malicious users to bypass intended access restrictions by sniffing the network for valid requests, related to lack of checking of nonce (aka server nonce) and nc (aka nonce-count or client nonce count) values.

Vendor Advisories

Synopsis Moderate: tomcat6 security and bug fix update Type/Severity Security Advisory: Moderate Topic Updated tomcat6 packages that fix several security issues and one bug arenow available for Red Hat Enterprise Linux 6The Red Hat Security Response Team has rated this update as having moderatesecurity imp ...
Synopsis Moderate: tomcat5 security update Type/Severity Security Advisory: Moderate Topic Updated tomcat5 packages that fix multiple security issues are nowavailable for Red Hat Enterprise Linux 5The Red Hat Security Response Team has rated this update as having moderatesecurity impact Common Vulnerabili ...
Synopsis Important: jbossweb security update Type/Severity Security Advisory: Important Topic Updated jbossweb packages that fix multiple security issues are nowavailable for JBoss Enterprise Application Platform 512 for Red HatEnterprise Linux 4, 5, and 6The Red Hat Security Response Team has rated this ...
Synopsis Important: jbossweb security update Type/Severity Security Advisory: Important Topic Updated jbossweb packages that fix multiple security issues are nowavailable for JBoss Enterprise Web Platform 512 for Red Hat EnterpriseLinux 4, 5, and 6The Red Hat Security Response Team has rated this update ...
Synopsis Moderate: tomcat5 security and bug fix update Type/Severity Security Advisory: Moderate Topic Updated tomcat5 packages that fix multiple security issues and two bugs arenow available for JBoss Enterprise Web Server 102 for Red HatEnterprise Linux 5 and 6The Red Hat Security Response Team has rat ...
Synopsis Moderate: tomcat6 security and bug fix update Type/Severity Security Advisory: Moderate Topic Updated tomcat6 packages that fix multiple security issues and three bugsare now available for JBoss Enterprise Web Server 102 for Red HatEnterprise Linux 5 and 6The Red Hat Security Response Team has r ...
Tomcat could be made to crash or expose sensitive information over the network ...
Certain AJP protocol connector implementations in Apache Tomcat 700 through 7020, 600 through 6033, 550 through 5533, and possibly other versions allow remote attackers to spoof AJP requests, bypass authentication, and obtain sensitive information by causing the connector to interpret a request body as a new request The HTTP Digest Ac ...
IntelligenceCenter uses a version of Tomcat that has several publicly documented vulnerabilities The most severe vulnerability allows an attacker to mount a denial of service attack or to obtain sensitive information by using a specially crafted header ...

References

CWE-264http://lists.opensuse.org/opensuse-security-announce/2012-02/msg00002.htmlhttp://lists.opensuse.org/opensuse-security-announce/2012-02/msg00006.htmlhttp://marc.info/?l=bugtraq&m=133469267822771&w=2http://marc.info/?l=bugtraq&m=136485229118404&w=2http://marc.info/?l=bugtraq&m=139344343412337&w=2http://rhn.redhat.com/errata/RHSA-2012-0074.htmlhttp://rhn.redhat.com/errata/RHSA-2012-0075.htmlhttp://rhn.redhat.com/errata/RHSA-2012-0076.htmlhttp://rhn.redhat.com/errata/RHSA-2012-0077.htmlhttp://rhn.redhat.com/errata/RHSA-2012-0078.htmlhttp://rhn.redhat.com/errata/RHSA-2012-0325.htmlhttp://secunia.com/advisories/57126http://svn.apache.org/viewvc?view=rev&rev=1087655http://svn.apache.org/viewvc?view=rev&rev=1158180http://svn.apache.org/viewvc?view=rev&rev=1159309http://tomcat.apache.org/security-5.htmlhttp://tomcat.apache.org/security-6.htmlhttp://tomcat.apache.org/security-7.htmlhttp://www.debian.org/security/2012/dsa-2401http://www.mandriva.com/security/advisories?name=MDVSA-2011:156http://www.redhat.com/support/errata/RHSA-2011-1845.htmlhttps://lists.apache.org/thread.html/06cfb634bc7bf37af7d8f760f118018746ad8efbd519c4b789ac9c2e@%3Cdev.tomcat.apache.org%3Ehttps://lists.apache.org/thread.html/8dcaf7c3894d66cb717646ea1504ea6e300021c85bb4e677dc16b1aa@%3Cdev.tomcat.apache.org%3Ehttps://lists.apache.org/thread.html/r3aacc40356defc3f248aa504b1e48e819dd0471a0a83349080c6bcbf@%3Cdev.tomcat.apache.org%3Ehttps://lists.apache.org/thread.html/r584a714f141eff7b1c358d4679288177bd4ca4558e9999d15867d4b5@%3Cdev.tomcat.apache.org%3Ehttps://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A19169https://www.rapid7.com/db/vulnerabilities/gentoo-linux-cve-2011-1184https://access.redhat.com/errata/RHSA-2011:1780https://nvd.nist.govhttps://usn.ubuntu.com/1252-1/https://www.rapid7.com/db/vulnerabilities/centos_linux-cve-2011-5062