2.1
CVSSv2

CVE-2019-14846

Published: 08/10/2019 Updated: 07/06/2021
CVSS v2 Base Score: 2.1 | Impact Score: 2.9 | Exploitability Score: 3.9
CVSS v3 Base Score: 7.8 | Impact Score: 5.9 | Exploitability Score: 1.8
Vector: AV:L/AC:L/Au:N/C:P/I:N/A:N

Vulnerability Summary

In Ansible, all Ansible Engine versions up to ansible-engine 2.8.5, ansible-engine 2.7.13, ansible-engine 2.6.19, were logging at the DEBUG level which lead to a disclosure of credentials if a plugin used a library that logged credentials at the DEBUG level. This flaw does not affect Ansible modules, as those are executed in a separate process.

Most Upvoted Vulmon Research Post

There is no Researcher post for this vulnerability
Would you like to share something about it? Sign up now to share your knowledge with the community.

Vulnerability Trend

Vulnerable Product Search on Vulmon Subscribe to Product

redhat ansible engine

debian debian linux 8.0

debian debian linux 9.0

opensuse backports sle 15.0

opensuse leap 15.1

redhat openstack 13.0

redhat ansible_engine 2.0

redhat ansible_engine 2.8.0

Vendor Advisories

Debian Bug report logs - #942188 ansible: CVE-2019-14846 Package: src:ansible; Maintainer for src:ansible is Harlan Lieberman-Berg <hlieberman@debianorg>; Reported by: Salvatore Bonaccorso <carnil@debianorg> Date: Fri, 11 Oct 2019 19:21:02 UTC Severity: important Tags: security, upstream Found in version ansible/2 ...
Synopsis Important: Ansible security update Type/Severity Security Advisory: Important Topic An update is now available for Ansible Engine 26Red Hat Product Security has rated this update as having a security impact of Important A Common Vulnerability Scoring System (CVSS) base score, which gives a detai ...
Synopsis Important: Ansible security and bug fix update Type/Severity Security Advisory: Important Topic An update is now available for Ansible Engine 2Red Hat Product Security has rated this update as having a security impact of Important A Common Vulnerability Scoring System (CVSS) base score, which giv ...
Synopsis Moderate: ansible security update Type/Severity Security Advisory: Moderate Topic An update for ansible is now available for Red Hat OpenStack Platform 130 (Queens) for RHEL 7Red Hat Product Security has rated this update as having a security impact of Moderate A Common Vulnerability Scoring Sys ...
Synopsis Important: Ansible security and bug fix update Type/Severity Security Advisory: Important Topic An update is now available for Ansible Engine 27Red Hat Product Security has rated this update as having a security impact of Important A Common Vulnerability Scoring System (CVSS) base score, which g ...
Synopsis Important: Ansible security and bug fix update Type/Severity Security Advisory: Important Topic An update is now available for Ansible Engine 28Red Hat Product Security has rated this update as having a security impact of Important A Common Vulnerability Scoring System (CVSS) base score, which g ...